Apple Mac: Was tun, wenn Time Machine kein Backup macht?

22. Dezember 2018

Waldorf PlugIns verhindern Mac Time Machine

Diese kurze News könnte so manchem Mac-User über Weihnachten das Leben erleichtern.

Problem: Time Machine bricht Backup ab

Vor Kurzem hat an unserem MAC-Audio-Rechner in der Redaktion das automatische Backup über Time Machine versagt. Nach ca. 200 GB Transfer erschien bei jedem erneuten Versuch eine Fehlermeldung, die uns mitteilte, dass auf Grund eines unbekannten Fehlers, Time Machine kein Backup erstellen könne.

Zunächst vermuteten wir einen Festplattenfehler. Eine automatische Reparatur durch das Festplattendienstprogramm führte zu keiner Verbesserung. Danach wurden nacheinander zwei nagelneue Platten ausgetauscht. Vergeblich. Ein befreundeter Mac-Spezialist (… nein, kein Selbsternannter, sondern ein für Apple tätiger Support-Mitarbeiter) checkte unseren Mac auf Herz und Nieren und fand schließlich den Übeltäter über das Dienstprogramm „Konsole“.

Vorgehensweise zur Fehlersuche

Konsole starten (findet ihr unter Dienstprogramme)

  • danach manuell über Time Machine ein Backup auslösen und warten, bis der Fehler eintritt
  • um nun den Fehler in Konsole zu lokalisieren, in das Eingabefeld der Konsole „backupd“ eingeben, danach zeigt Konsole nur noch die entsprechenden Zeilen an, in denen Time Machine Fehler ausgelöst hat
  • Nun „leider“ Zeile für Zeile anklicken und im unteren Drittel von Konsole darauf achten, ob das Kürzel „src“ (Source für Quelle) auftaucht.

In unserem Fall tauchte hier der Name Waldorf auf und der Pfad zu den „Waldorf-Presets“ in der Library  (Library/Audio/Presets/Waldorf)

Fehlerbehebung

Radikal den Ordner löschen (und seine Presets verlieren) ist eine Möglichkeit. Den besagten Ordner über die Time Machine Systemeinstellungen vom Backup ausschließen, die elegantere. Beides führt zum Erfolg und Time Machine verrichtet seinen Dienst wieder.

Waldorf Support

Nach Rückmeldung beim Waldorf Support bestätigte man uns, dass der Fehler bekannt sei (!!!). Wir waren ein wenig „überrascht“. Schließlich hätten wir uns viel Zeit gespart, wenn Waldorf diese Information öffentlich bekannt gegeben hätte.

Die gute Nachricht: Waldorf arbeitet bereits an einer Lösung. Wir geben Entwarnung, so bald Waldorf den Fehler beseitigen konnte.

Forum
  1. Profilbild
    SimonChiChi  AHU

    … perfektes Timing. Seit ein paar Tagen will meine TM nicht mehr. Soeben den Rat oben befolgt und den Waldorf-Ordner aus dem BU genommen – jetzt funzt es wieder. Danke Peter.

  2. Profilbild
    Radig

    Der Fehler trat bei Largo bereits vor einen Jahr auf. Das Problem ist, dass vor dem Verzeichnisnamen der Presets (vor Waldorf) ein „?“ als erstes Zeichen steht. Das sieht man allerdings nur auf der Kommandozeile der Console und damit kommt MT nicht klar. Man kann also auf Kommandoebene einfach das Verzeichnis „?Waldorf“ in „Waldorf“ umbenennen. Die letzte Version von Largo soll das Problem nicht mehr haben. Steht jedenfalls in den Release Notes.

      • Profilbild
        chk  

        Hat doch Radig gerade bestätigt, dass Waldorf das Problem in der aktuellen Version des Largo beseitigt hat.

    • Profilbild
      Tyrell  RED 1

      Dann kann ich jetzt im Text zumindest rausnehmen, dass es am MOJAVE Update lag.

      • Profilbild
        Radig

        Stimmt. Bei mir war der Effekt im Zusammenhang mit der Installation von Sierra aufgetreten. Es liegt aber definitiv an Waldorf ….

  3. Profilbild
    TobyB  RED

    Hallo Peter,

    NI ist auch so ein Kandidat für verbotene Zeichen in Ordnernamen.

    Terminal und dann log show –predicate „category=’TMLogError'“ oder
    log show –predicate „category=’TMLogError'“ –style syslog –start “
    Start entspricht dem ersten Auftreten des Fehlers. Geht schneller als mit der Konsole. Ich würde anstelle von Time Machine eher Carbon Copy Cloner einsetzen. Time Machine hat den Nachteil, das des unter Umständen alte Backups löscht.

  4. Profilbild
    Robocob11  

    Bei mir ging auch ncihts mehr. Habe es vor einigen Wochen einfach sein lassen mit TM und einfach Datein manuell auf HDs geschoben. Dank dieses Artikels läuft es jetzt wieder! Super.

  5. Profilbild
    PLan9  

    Auch wenn Waldorf sich den Schuh anzieht. Das ist ein Betriebssystem Problem.
    Apple sollte da tätig werden. Es sollte kein Verzeichniss erzeugt werden können das nicht gültig ist.
    Auch ist die Fehlermeldung nicht aussagekräftig.

    • Profilbild
      Robocob11  

      Klar hast du recht was Apple angeht. Das man sich hier einen Wolf sucht, könnte Apple deutlich kundenorientierter gestalten. Auf der anderen Seite habe ich minimum 100 PlugIns auf dem Rechner. Das Problem taucht aber nur bei Waldorf auf. Da kann ich dir also nicht Recht geben. Wenn selbst Mini-Programmierbuden das gebacken bekommen, wieso Waldorf nicht?

      • Profilbild
        PLan9  

        Nochmal, Es ist ein Problem des OS. Da gibt es nichts zu diskutieren. Es ist so. Auch wenn das OS von Apple ist. Selbst Microsoft hat das drauf sowas abzufangen. Bei Ordner und Filenamen die nicht gültig sind muss beim erzeugen ein Fehler gemeldet werfen und dieser Order bzw. File darf nicht erzeugt werden.

        • Profilbild
          Jupiter Six

          Robocob wiederspricht dir doch gar nicht, sondern sagt lediglich, dass alle anderen Hersteller mit dem Apple-Fehler umgehen konnten, Waldorf aber bislang nicht. Außerdem hat Waldorf den Fehler bislang nicht offen kommuniziert – daher auch ein dickes Danke an Amazona. Also gibt es da tatsächlich nichts zu diskutieren, sondern Waldorf soll einfach den Job machen, den die andereren längst gemacht haben. Und selbst wenn es ein Apple-Fehler ist, sollte Waldorf auf den Apple-Fehler hinweisen und seine Käufer darüber informieren, dass Backups mit ihren Plugins daher nicht mehr laufen. Hätte mir ein paar Tage Zeit gespart.

        • Profilbild
          TobyB  RED

          Hallo Plan9,

          in den Guidelines für Anwender/Entwickler für MacOS X steht eindeutig von #/%$?()!§&=“@.;: und anderen Sonderzeichen die Finger zu lassen. Und dies bei der Namenskonvention für Ordner und Dateinamen zu berücksichtigen. Den nicht alles was auf der GUI hübsch und schön ist, muss auf der Kommandozeile o.ä auch richtig und gültig sein. Da wir nicht wissen mit was für einer IDE oder RAID Waldorf unterwegs ist, kann man auch nicht nachvollziehen, wie der Fehler durchgerutscht ist. Zum anderen werden einige Zeichen eben doch von MacOS abgefangen nur eben das ? nicht. Das warum sollte klar sein. Stichwort reguläre Ausdrücke. Den Unterschied merkt der Anwender/Entwickler spätestens dann, wenn am Terminal ein fröhliches mkdir ?rdner einen Ordner erzeugt und dieser ?rdner nun wieder gelöscht werden soll. Noch spassiger ist ein %Zeichen. Und noch lustiger wird dieses in Samba-Laufwerken oder anderen Shares. Windows hier als Vergleich anzubringen ist nett, aber nicht zielführend, Windows tickt komplett anders.

Kommentar erstellen

Die AMAZONA.de-Kommentarfunktion ist Ihr Forum um sich persönlich zu den Inhalten der Artikel auszutauschen. Sich daraus ergebende Diskussionen sollten höflich und sachlich geführt werden. Haben Sie eigene Erfahrungen mit einem Produkt gemacht, stellen Sie diese bitte über die Funktion Leser-Story erstellen ein. Für persönliche Nachrichten verwenden Sie bitte die Nachrichtenfunktion im Profil.